Delay with USPS Tracking updates

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Aug 08, 2025 - 07:04 UTC

Investigating

We are experiencing difficulties in receiving USPS Tracking updates. During this time, tracking updates may be delayed but will be sent once the carrier’s API is restored.
Posted Aug 08, 2025 - 03:07 UTC
This incident affected: Carrier API (USPS).