Temporary disruption affecting USPS Military and U.S. Territory Shipments

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 18:21 UTC

Update

We are continuing to investigate this issue.
Posted Mar 12, 2026 - 18:26 UTC

Investigating

We are currently experiencing a temporary disruption affecting label generation for USPS shipments destined for U.S. military addresses and certain U.S. territories.
We are working with the carrier to restore normal service as quickly as possible.
Posted Mar 12, 2026 - 16:52 UTC
This incident affected: Carrier API (USPS).