UPS New Account Registration Outage
Incident Report for Shippo
Resolved
This incident has been resolved.
Posted Jul 14, 2022 - 18:30 PDT
Investigating
We are experiencing an issue affecting the UPS Account Activation functionality. We will provide updates as we have them.
Posted Jul 13, 2022 - 18:20 PDT
This incident affected: Shippo REST API, Shippo Web Dashboard, Shippo Platform API and Carrier APIs (UPS).