Degraded Web Dashboard Performance
Incident Report for Shippo
Resolved
Due to the small number of affected users, we are closing this incident. We are still addressing it with upmost urgency and actively working with affected customers to remedy the situation.
Posted Dec 09, 2023 - 08:37 PST
Investigating
We are investigating reports of orders not displaying, on the Orders tab, in the Shippo Web Dashboard.
Posted Dec 08, 2023 - 17:17 PST
This incident affected: Shippo Web Dashboard.