Order Fulfillment Disruption

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted May 21, 2022 - 00:29 UTC

Monitoring

An issue causing fulfillments to be backed up has been discovered and fixed, all unprocessed fulfillments are currently being processed. We are continuing to monitor the situation.
Posted May 20, 2022 - 15:36 UTC