Elevated error rate on USPS Transaction API

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 16:54 UTC

Monitoring

We started seeing recovery for label generation , we are monitoring things for a while
Posted Mar 12, 2026 - 16:37 UTC

Update

We are continuing to investigate this issue.
Posted Mar 12, 2026 - 16:36 UTC

Investigating

We are currently experiencing an issue affecting USPS label generation via the API, which is impacting our ability to create both domestic and international USPS labels.

Our team is actively investigating the issue and is in contact with USPS to identify the cause and restore normal service as quickly as possible.
Posted Mar 12, 2026 - 16:21 UTC
This incident affected: Carrier API (USPS).