USPS scheduled Maintenance on Tracking API

Incident Report for Shippo

Resolved

The maintenance has been completed
Posted Mar 16, 2025 - 00:09 PDT

Investigating

USPS will be performing maintenance on their Product Tracking and Reporting APIs from March 15, 2025, 05:00 PM PST to March 16, 2025, 12:00 AM (Midnight) PST.
During this time, Product Tracking and Reporting information will not be available for any USPS shipments.
Posted Mar 15, 2025 - 19:33 PDT
This incident affected: Carrier API (USPS).