Elevated error rate on Deutsche Post Tracking Service

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 12:46 UTC

Investigating

We’ve detected an elevated error rate from Deutsche Post. The carrier has confirmed they are currently experiencing an issue impacting Tracking service, and we’re actively monitoring the situation. During this time, updates may be delayed but will be sent once the carrier's API is restored.
Posted Feb 18, 2026 - 11:23 UTC
This incident affected: Carrier API (Deutsche Post).