Elevated error rate on Better trucks Shipment

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Aug 24, 2025 - 01:40 UTC

Investigating

We have detected an elevated error rate from Better trucks Shipment API. Our team has contacted the carrier and we are monitoring the situation.
Posted Aug 23, 2025 - 11:54 UTC
This incident affected: Carrier API (Better Trucks).