Elevated error rate on DHL eCommerce Transaction API

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Jul 29, 2026 - 19:48 UTC

Identified

Carrier Confirmed they have an major outage on their end ,they are actively working on this to resolve the issue
Posted Jul 29, 2026 - 19:27 UTC

Investigating

We have detected an elevated error rate from DHL eCommerce Transaction API. Our team has contacted the carrier and we are monitoring the situation. During this time, Label generation will be unavailable please retry once the carrier's API is restored.
Posted Jul 29, 2026 - 19:25 UTC
This incident affected: Carrier API (DHL eCommerce).