Fedex Partial Outage
Incident Report for Shippo
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 12:29 PDT
Identified
We are experiencing an issue affecting Fedex. Fedex is aware of the issue and working toward resolution. We will provide updates as we have them.
Posted Apr 23, 2024 - 11:01 PDT
This incident affected: Carrier APIs (FedEx).