USPS having issues with Tracking API

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Mar 16, 2025 - 11:57 PDT

Monitoring

We’ve now started receiving all missed updates and continue to monitor the service
Posted Mar 16, 2025 - 09:39 PDT

Investigating

USPS had scheduled maintenance today, it looks like they have issue again due to the changes that happened on carrier end
Posted Mar 16, 2025 - 06:14 PDT
This incident affected: Carrier API (USPS).