Elevated error rate on FedEx Transaction & shipment service

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 19:02 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 26, 2026 - 18:57 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2026 - 18:12 UTC

Identified

FedEx confirmed they are having multiple issue on their rest API service , we are closely working with carrier for resolution
Posted Jun 26, 2026 - 17:17 UTC

Investigating

We are currently experiencing an elevated error rate affecting label generation for FedEx BYOA account. Our team is actively investigating the issue ,We will share further updates as soon as they are available.
Posted Jun 26, 2026 - 16:48 UTC
This incident affected: Carrier API (FedEx).