Mondial Relay Outage
Incident Report for Shippo
Resolved
This incident has been resolved.
Posted Dec 21, 2023 - 13:47 PST
Investigating
We are experiencing an issue affecting label purchase and tracking from Mondial Relay. We will provide updates as we have them.
Posted Dec 21, 2023 - 12:40 PST
This incident affected: Shippo REST API, Shippo Web Dashboard, Shippo Platform API and Carrier APIs (Mondial Relay).