Elevated error rate on Poste Italiane services

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Jul 16, 2025 - 19:04 UTC

Investigating

We are experiencing multiple issues with Poste Italiane services. We have reached out to the carrier and and actively monitoring the status of these issues and will provide further updates soon.
Posted Jul 16, 2025 - 16:14 UTC
This incident affected: Carrier API (Poste Italiane).