USPS Tracking Number Issue
Incident Report for Shippo
Resolved
This incident has been resolved
Posted Dec 12, 2022 - 22:05 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 12, 2022 - 18:13 PST
Investigating
Shippo recently issued a fix pertaining to a reported issue of some USPS shipping labels being created with pre-existing tracking information. We are currently monitoring that the issue is resolved
Posted Dec 12, 2022 - 18:10 PST