Elevated error rate on DHL Express label generation

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 00:08 UTC

Investigating

We are currently experiencing elevated label creation errors affecting shipments using Shippo’s DHL Express master account only. Our team is actively investigating the issue and working toward a resolution.

We’ll provide further updates as more information becomes available.
Posted Aug 28, 2026 - 19:39 UTC
This incident affected: Carrier API (DHL Express).