USPS Scheduled Maintenance

Scheduled for Sep 30, 01:00 - 05:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 23, 2026 - 18:03 UTC

Scheduled

Hi Team, USPS has a scheduled maintenance window on September 30, 2026 at 01:00 AM UTC. This will last for up to 4 hours. During this time, label generation for International, Military, and U.S. Territory shipments will be unavailable. We recommend retrying any failed requests after the maintenance is complete.
Posted Sep 23, 2026 - 17:34 UTC
This scheduled maintenance affects: Carrier API (USPS).