Degraded Orders Page Performance

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 05:36 UTC

Investigating

We are currently investigating an issue causing intermittent degradation of the Orders page in the Shippo web application. Some customers may experience empty or incomplete order listings while using the Orders page.

Our team is actively investigating the issue and working to restore full functionality as quickly as possible. We will provide another update as soon as more information becomes available.
Posted Jun 26, 2026 - 04:34 UTC
This incident affected: Shippo Web Dashboard.