USPS Manifest outage

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Mar 08, 2026 - 13:19 UTC

Investigating

Hey team, we had a maintenance window for USPS. Although the maintenance has been completed, we are currently seeing a high error rate for manifest. This should not affect shipments but we are seeking clarification from USPS.

We will keep you updated as soon as we have more information.
Posted Mar 08, 2026 - 10:32 UTC
This incident affected: Carrier API (USPS).