Elevated error rate on Deutsche Post Tracking

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 10:59 UTC

Monitoring

We have detected an elevated error rate from the Deutsche Post Tracking API. The carrier team has identified an issue on their end and is actively monitoring it.
Posted Dec 04, 2025 - 10:31 UTC
This incident affected: Carrier API (Deutsche Post).