Elevated error rate on Better trucks Shipment Service

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Aug 17, 2025 - 13:27 UTC

Investigating

We are experiencing some issues with Better trucks on Shipment service that started around 12:10 PM UTC, Aug 17, 2025. We have reached out to the carrier and we actively monitoring the status of these issue.
Posted Aug 17, 2025 - 12:36 UTC
This incident affected: Carrier API (Better Trucks).