The Canadian Union of Postal Workers (CUPW) has moved from a full, national strike to rotating strikes across select areas in Canada. As a result, Canada Post has resumed operations, and you can once again create and purchase Canada Post labels through Shippo. However, with rotating strike activity ongoing, delivery timelines remain unpredictable, and service guarantees are currently suspended. What else to expect
Rotating strike activity may be isolated to specific locations, affecting those areas for a specified period of time. During a rotating strike, Canada Post will accept, process and deliver mail and parcels in unaffected areas, but you can still expect delays. Once an item is inducted into Canada Post’s network, it will be secure but cannot be retrieved if that facility is affected by a rotating strike. Items will be delivered as quickly as possible after a disruption is over and operations resume.
Customers should expect delays in pickup, processing, and delivery as operations stabilize. If you choose to ship via Canada Post, please keep these considerations in mind. Additionally, please be aware that further strike action could occur with little to no notice, meaning this period remains unpredictable.
For the latest information including areas affected, visit Canada Post's negotiations updates page http://canadapost.ca/negotiations.
Posted Oct 24, 2025 - 00:27 UTC
Update
We are continuing to investigate this issue.
Posted Sep 27, 2025 - 19:59 UTC
Update
Due to a national strike by the Canadian Union of Postal Workers effective September 25th, customers are asked to refrain from mailing items to Canada via USPS, Royal Mail and Australia Post or domestically via Canada Post until further notice. This will impact shipments currently in transit as well as new shipments. It’s unclear how long the strike will last.
To ensure your packages don’t get delayed or lost, Shippo will be disabling all USPS, Royal Mail and AusPost service levels in our App and API for packages with a Canadian destination.
Your options with Shippo Shippo offers alternative carrier options to keep your shipments moving to Canada, such as UPS, FedEx, and DHL Express. Log in to your Shippo account today to view available shipping options for destinations throughout Canada.
Posted Sep 26, 2025 - 23:15 UTC
Update
We are continuing to investigate this issue.
Posted Sep 26, 2025 - 23:12 UTC
Investigating
Due to a national strike by the Canadian Union of Postal Workers effective September 25th, customers are asked to refrain from mailing items to Canada via USPS or domestically via Canada Post until further notice. This will impact shipments currently in transit as well as new shipments. It’s unclear how long the strike will last.
To ensure your packages don’t get delayed or lost, Shippo will be disabling all USPS service levels in our App and API for packages with a Canadian destination. Your options with Shippo
Shippo offers alternative carrier options to keep your shipments moving to Canada, such as UPS, FedEx, and DHL Express. Log in to your Shippo account today to view available shipping options for destinations throughout Canada.