Observing Interruption in Receiving USPS Tracking Events

Incident Report for Shippo

Resolved

We have started receiving tracking updates from USPS again. Service has returned to normal, and the issue has been resolved.
Posted Mar 13, 2026 - 15:26 UTC

Investigating

We are experiencing an interruption in USPS tracking events from the carrier. Our team has reached out to USPS and is actively monitoring the situation. We will provide further updates as soon as they become available.
Posted Mar 13, 2026 - 14:38 UTC
This incident affected: Carrier API (USPS).