Email notification delay

Incident Report for Shippo

Resolved

The connectivity issues have been resolved and email notifications should be operating as expected.
Posted Jun 18, 2021 - 23:36 UTC

Identified

Our email provider is experiencing connectivity issues, causing delays sending email notifications. We will monitor and update when our provider has fixed the issues.
Posted Jun 18, 2021 - 21:51 UTC