DHL Express Account Outage
Incident Report for Shippo
Resolved
DHL Express Account is back to operational.
Posted Mar 09, 2024 - 14:10 PST
Identified
We’re currently experiencing an outage that is preventing users on Shippo’s DHL carrier account from purchasing labels. We are in close contact with DHL Express, as they resolve the issue. They have informed us that DHL Express label generation may be unavailable until late Saturday, 3/9/24.

We apologize for any inconvenience this may cause and appreciate your patience and understanding during this time.
Posted Mar 08, 2024 - 14:26 PST
Investigating
Shippo’s DHL Express Account is showing partial outage. We are actively working with DHL Express to identify the problem. We will provide updates as we have them.
Posted Mar 08, 2024 - 10:51 PST
This incident affected: Shippo REST API, Shippo Web Dashboard, Shippo Platform API and Carrier APIs (DHL Express).