Shippo Services Down
Incident Report for Shippo
Resolved
An infrastructure failure around 9:47PM PST resulted in partial outage until 10:06PM PST, then a complete outage from 10:07 - 10:12PM PST on October 10, 2023.
Posted Oct 10, 2023 - 22:34 PDT
Investigating
We are currently experiencing a partial outage and are investigating
Posted Oct 10, 2023 - 22:06 PDT
This incident affected: Shippo REST API, Shippo Web Dashboard, and Shippo Platform API.