Delay in USPS Tracking Updates

Incident Report for Shippo

Resolved

This incident has been resolved.
Posted Mar 22, 2026 - 09:03 UTC

Investigating

We are currently experiencing an interruption in tracking events from USPS. Our team is actively monitoring the situation, and we will keep you posted with updates.
Posted Mar 22, 2026 - 02:59 UTC
This incident affected: Carrier API (USPS).