Degraded System Performance and Errors
Incident Report for Shippo
Resolved
We have addressed the problem affecting the Dashboard and API services.
Posted 11 days ago. Oct 10, 2017 - 19:19 PDT
Identified
We have identified an issue that is causing errors and degraded performance for the Dashboard and API services.
Posted 11 days ago. Oct 10, 2017 - 18:47 PDT