We’ve started seeing a few successful label generations on our graph, but we haven’t received any updates from Canada Post yet. We’ll continue to monitor this and keep you updated once the carrier confirms.
Posted Dec 25, 2025 - 14:47 UTC
Update
We heard back from Canada Post, and unfortunately there’s no new update yet. Their team has been working overnight, but the APIs are still largely failing. They’ll share an update once things are stable.
Posted Dec 24, 2025 - 14:25 UTC
Monitoring
Update: Canada Post has confirmed their systems are stabilized; however, error rates remain elevated. We are seeing some successful transactions and are continuing to monitor the service until full operational stability is confirmed.
Posted Dec 24, 2025 - 02:52 UTC
Identified
Canada Post has confirmed an outage on their end and their team is actively working to resolve the issue. We will share updates as more information becomes available.
Posted Dec 23, 2025 - 20:19 UTC
Investigating
We have detected an elevated error rate from Canada post Transaction API. Our team has contacted the carrier and we are monitoring the situation. During this time, label generation is affected.
Posted Dec 23, 2025 - 20:09 UTC
This incident affected: Carrier API (Canada Post).